Bienvenido a la Comunidad de Treehouse

¿Quieres colaborar en errores de código? ¿Tienes errores que necesitan comentarios? ¿Buscas un par de ojos adicionales en tu último proyecto? aquí.

¿Buscas aprender algo nuevo?

Treehouse ofrece una prueba gratuita de siete días para estudiantes nuevos. Obtén acceso a miles de horas de contenido y únete a miles de

Inicia tu prueba gratuita

PHP Configure Su Entorno de Desarrollo Local

El Servidor Apache NO SE ENCIENDE (MAMP)

Solo mysql está activado, busqué ayuda en línea pero no encuentro nada. Solo lo opuesto, ¿por qué es así en el mío?

Hola Ceil-lan, solo me preguntaba, ¿qué puerto está usando MAMP para tu servidor apache? Esto se encuentra dentro de preferencias y haz clic en la pestaña de puertos, apache generalmente se ejecuta en el puerto 80

¿Hay algo más usando el puerto 80?

Si usas Windows: ejecuta cmd como administrador e ingresa netstat -abno

esto listará todos los procesos y el puerto en el que se están ejecutando, busca el puerto 80. Ese puede ser el problema.

Si no, aquí hay un artículo sobre mamp:

https://appsolute.zendesk.com/hc/en-us/articles/215197286-My-Apache-Server-will-not-start-

1 Respuesta

Ceil-Ian Maralit : Llego un poco tarde, así que es posible que ya hayas encontrado una solución. Sin embargo, aquí hay una respuesta alternativa por si otra persona se encuentra con este problema en el futuro.

Estaba ejecutando MAMP (no pro) en Windows 10 (64-bit) y el servidor apache no se iniciaba. Encontré esta solución en Stack Overflow.

  1. Mamp -> Preferencias
  2. PHP -> Cambiar versión estándar a 7.2.14 (O una opción diferente a la que tiene ahora)
  3. Haz clic en Aceptar.

Mamp debería reiniciarse y el servidor apache debería ejecutarse normalmente ahora.

Esto funcionó perfectamente. ¡Gracias!